Web Interstitial Ad Example

Help: Unable to connect using bitcoinrpc in python to my local bitcoin node

[ad_1]

For the life of me I can’t figure this out…

I was having trouble getting my machine to port forward 8332, but 8333 seemed fine, so I ended up moving my rpcport to 8334, which seems to connect now but I keep getting this error now on the following python script…

My Python Script(named bitcoin104.py)

from bitcoinrpc.authproxy import AuthServiceProxy, JSONRPCException
# rpc_user and rpc_password are set in the bitcoin.conf file
#rpc_user = "myusername"
#rpc_password = "myuserpass"
rpc_connection = AuthServiceProxy("http://myusername:[email protected]:8334")
print(rpc_connection.get_info())

When i run it I get the following error…

PS D:\PROJECTS\python38_env_bitcoin\src\hellobitcoin101> python .\bitcoin104.py
Traceback (most recent call last):
  File ".\bitcoin104.py", line 8, in <module>
    print(rpc_connection.get_info())
  File "D:\PROJECTS\python38_env_bitcoin\.venv\lib\site-packages\bitcoinrpc\authproxy.py",
line 139, in __call__
    response = self._get_response()
  File "D:\PROJECTS\python38_env_bitcoin\.venv\lib\site-packages\bitcoinrpc\authproxy.py", line 179, in _get_response
    http_response = self.__conn.getresponse()
  File "c:\users\hanso\appdata\local\programs\python\python38\lib\http\client.py", line 1344, in getresponse
    response.begin()
  File "c:\users\hanso\appdata\local\programs\python\python38\lib\http\client.py", line 307, in begin
    version, status, reason = self._read_status()
  File "c:\users\hanso\appdata\local\programs\python\python38\lib\http\client.py", line 276, in _read_status
    raise RemoteDisconnected("Remote end closed connection without"*
http.client.RemoteDisconnected: Remote end closed connection without response

Here are all the options i have set in my bitcoin.conf file in my local directory for bitcoin…

*port=8333
timeout=30
printtoconsole=1
chain=main
#rpcallowip=127.0.0.1
rpcpassword=myuserpass
rpcport=8334
rpcuser=myusername
server=1*

I ended up commenting out rpcallowip just to give it the best chance of working…

Should also note the node seems to be running fine otherwise, so it is definitely up and running, and when I was first playing around with setup I left the port open for a day and had outside connections happening… So i think that is setup ok. Other then possible something I am doing wrong with the bitcoin.conf file.

And since I switched to port 8334 from 8332 I am at least now not getting a machine/host blocked request message. It seems to at least be communicating with the node now as well. But for some reason it doesn’t seem to like the query?

I have no idea what I am doing wrong? Any help would be greatly appreciated as have been banging my head against the monitor all day on this now….

[ad_2]

Source link